What’s Vulnerable › Vulnerabilities
CVE-2025-40908: YAML-LibYAML prior to 0.903.0 for Perl uses 2-args open, allowing existing files to be modified
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-01 · updated 2026-06-17
- Weakness: CWE-552
Description
YAML-LibYAML prior to 0.903.0 for Perl uses 2-args open, allowing existing files to be modified
Affected products
- Ingydotnet Yaml-Libyaml: before 0.903.0 — fixed in 0.903.0
How to fix
Upgrade to a fixed version: Ingydotnet Yaml-Libyaml 0.903.0. Check the vendor advisory for mitigations.
References
- https://github.com/ingydotnet/yaml-libyaml-pm/issues/120
- https://github.com/ingydotnet/yaml-libyaml-pm/pull/121
- https://github.com/ingydotnet/yaml-libyaml-pm/pull/122
Get alerted when CVE-2025-40908 or the next vulnerability affects your stack