What’s Vulnerable › Vulnerabilities
CVE-2025-40912: CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
- Weakness: CWE-1395
Description
CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode. CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be susceptible to CVE-2019-17362.
Affected products
- MIK CryptX: from 0.002 before 0.065 — fixed in 0.065
How to fix
Upgrade to a fixed version: MIK CryptX 0.065. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40912 or the next vulnerability affects your stack