What’s Vulnerable › Vulnerabilities
CVE-2025-40928: JSON::XS before version 4.04 for Perl has an integer buffer overflow causing a segfault when parsing crafted JSON, enabling denial-of-service attacks or other unspecified impact
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-08 · updated 2026-06-17
- Weakness: CWE-122
Description
JSON::XS before version 4.04 for Perl has an integer buffer overflow causing a segfault when parsing crafted JSON, enabling denial-of-service attacks or other unspecified impact
Affected products
- MLEHMANN JSON::XS: before 4.04 — fixed in 4.04
How to fix
Upgrade to a fixed version: MLEHMANN JSON::XS 4.04. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/MLEHMANN/JSON-XS-4.03/source/XS.xs#L256
- https://security.metacpan.org/patches/J/JSON-XS/4.03/CVE-2025-40928-r1.patch
- http://www.openwall.com/lists/oss-security/2025/09/08/2
- https://lists.debian.org/debian-lts-announce/2025/09/msg00033.html
Get alerted when CVE-2025-40928 or the next vulnerability affects your stack