What’s Vulnerable › Vulnerabilities
CVE-2025-40942
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-250
Description
A vulnerability has been identified in TeleControl Server Basic (All versions < V3.1.2.4). Affected application contains a local privilege escalation vulnerability that could allow an attacker to run arbitrary code with elevated privileges.
Affected products
- Siemens TeleControl Server Basic: before 3.1.2.4 — fixed in 3.1.2.4
How to fix
Upgrade to a fixed version: Siemens TeleControl Server Basic 3.1.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40942 or the next vulnerability affects your stack