What’s Vulnerable › Vulnerabilities
CVE-2025-4099: List Children <= 2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The List Children plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'list_children' shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- theandystratton List Children: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: theandystratton List Children 2.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/list-children/trunk/list_children.php#L26
- https://plugins.trac.wordpress.org/changeset/3284430/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/538b4d4b-f8c6-44db-89d2-d345bfbfecb2?source=cve
Get alerted when CVE-2025-4099 or the next vulnerability affects your stack