What’s Vulnerable › Vulnerabilities
CVE-2025-4102: Beaver Builder Plugin (Starter Version) <= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-20 · updated 2026-06-17
- Weakness: CWE-434
Description
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.
Affected products
- beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder: before 2.9.1.1 — fixed in 2.9.1.1
How to fix
Upgrade to a fixed version: beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder 2.9.1.1. Check the vendor advisory for mitigations.
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2eb4608f-fa4f-444c-a857-c9059777a70b?source=cve
- https://www.wpbeaverbuilder.com/change-logs/?utm_medium=bb-lite&utm_source=repo-readme&utm_campaign=repo-changelog-page
Get alerted when CVE-2025-4102 or the next vulnerability affects your stack