What’s Vulnerable › Vulnerabilities
CVE-2025-41068: Reachable Assertion vulnerability in Open5GS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-617
Description
Reachable Assertion vulnerability in Open5GS up to version 2.7.6 allows attackers with connectivity to the NRF to cause a denial of service. This is achieved by sending the creation of an NF with an invalid type via SBI and then requesting its data. The NRF executes a check that crashes the process, leaving the discovery service unresponsive.
Affected products
- Open5GS: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: Open5GS 2.7.5. Check the vendor advisory for mitigations.
References
- https://open5gs.org/open5gs/release/2025/07/19/release-v2.7.6.html
- https://www.incibe.es/en/incibe-cert/notices/aviso/multiple-vulnerabilities-newplanes-open5gs
Get alerted when CVE-2025-41068 or the next vulnerability affects your stack