What’s Vulnerable › Vulnerabilities
CVE-2025-41227: Denial-of-Service Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-400
Description
VMware ESXi, Workstation, and Fusion contain a denial-of-service vulnerability due to certain guest options. A malicious actor with non-administrative privileges within a guest operating system may be able to exploit this issue by exhausting memory of the host process leading to a denial-of-service condition.
Affected products
- VMware Cloud Foundation: 5.x, 4.5.x
- VMware ESXi: from 8.0 before ESXi80U3se-24659227; from 7.0 before ESXi70U3sv-24723868 — fixed in ESXi70U3sv-24723868, ESXi80U3se-24659227
- VMware Fusion: from 13.x before 13.6.3 — fixed in 13.6.3
- VMware Telco Cloud Infrastructure: 3.x, 2.x
- VMware Telco Cloud Platform: 5.x, 4.x, 3.x, 2.x
- VMware Workstation: from 17.x before 17.6.3 — fixed in 17.6.3
How to fix
Upgrade to a fixed version: VMware ESXi ESXi70U3sv-24723868, ESXi80U3se-24659227; VMware Fusion 13.6.3; VMware Workstation 17.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41227 or the next vulnerability affects your stack