What’s Vulnerable › Vulnerabilities
CVE-2025-41228: VMware ESXi and vCenter Server Reflected Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware ESXi and vCenter Server contain a reflected cross-site scripting vulnerability due to improper input validation. A malicious actor with network access to the login page of certain ESXi host or vCenter Server URL paths may exploit this issue to steal cookies or redirect to malicious websites.
Affected products
- VMware Cloud Foundation: 5.x, 4.5.x
- VMware ESXi: from 8.0 before ESXi80U3se-24659227; from 7.0 before ESXi70U3sv-24723868 — fixed in ESXi70U3sv-24723868, ESXi80U3se-24659227
- VMware Telco Cloud Infrastructure: 3.x,2.x
- VMware Telco Cloud Platform: 5.x, 4.x, 3.x, 2.x
- VMware vCenter Server: from 8.0 before 8.0 U3e — fixed in 8.0 U3e
How to fix
Upgrade to a fixed version: VMware ESXi ESXi70U3sv-24723868, ESXi80U3se-24659227; VMware vCenter Server 8.0 U3e. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41228 or the next vulnerability affects your stack