What’s Vulnerable › Vulnerabilities
CVE-2025-41239: vSockets information-disclosure vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-15 · updated 2026-06-17
- Weakness: CWE-908
Description
VMware ESXi, Workstation, Fusion, and VMware Tools contains an information disclosure vulnerability due to the usage of an uninitialised memory in vSockets. A malicious actor with local administrative privileges on a virtual machine may be able to exploit this issue to leak memory from processes communicating with vSockets.
Affected products
- VMware Cloud Foundation: 5.x, 4.5.x
- VMware ESXi: from 8.0 before ESXi80U3f-24784735; from 8.0 before ESXi80U2e-24789317; from 7.0 before ESXi70U3w-24784741 — fixed in ESXi70U3w-24784741, ESXi80U2e-24789317, ESXi80U3f-24784735
- VMware Fusion: from 13.x before 13.6.4 — fixed in 13.6.4
- VMware Telco Cloud Infrastructure: 3.x, 2.x
- VMware Telco Cloud Platform: 5.x, 4.x, 3.x, 2.x
- VMware Tools: from 13.x.x before 13.0.1.0; from 12.x.x, 11.x.x, before 12.5.3 — fixed in 12.5.3, 13.0.1.0
- VMware Workstation: from 17.x before 17.6.4 — fixed in 17.6.4
How to fix
Upgrade to a fixed version: VMware ESXi ESXi70U3w-24784741, ESXi80U2e-24789317, ESXi80U3f-24784735; VMware Fusion 13.6.4; VMware Tools 12.5.3, 13.0.1.0; VMware Workstation 17.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41239 or the next vulnerability affects your stack