What’s Vulnerable › Vulnerabilities
CVE-2025-41242: CVE-2025-41242: Path traversal vulnerability on non-compliant Servlet containers
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-18 · updated 2026-06-17
- Weakness: CWE-22
Description
Spring Framework MVC applications can be vulnerable to a “Path Traversal Vulnerability” when deployed on a non-compliant Servlet container. An application can be vulnerable when all the following are true: * the application is deployed as a WAR or with an embedded Servlet container * the Servlet container does not reject suspicious sequences https://jakarta.ee/specifications/servlet/6.1/jakarta-servlet-spec-6.1.html#uri-path-canonicalization * the application serves static resources https://docs.spring.io/spring-framework/reference/web/webmvc/mvc-config/static-resources.html#page-title with Spring resource handling We have verified that applications deployed on Apache Tomcat or Eclipse Jetty are not vulnerable, as long as default security features are not disabled in the configuration. Because we cannot check exploits against all Servlet containers and configuration variants, we strongly recommend upgrading your application.
Affected products
- Maven Org.Springframework:Spring-Webmvc: from 6.2.0 before 6.2.10; from 6.1.0 through 6.1.21; from 6.0.0 through 6.0.29; from 5.3.0 through 5.3.43; 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.2.4, 6.2.5 (+90) — fixed in 6.2.10
- Spring Framework: from 6.2.x before 6.2.10; from 6.1.x before 6.1.22; from 5.3.x before 5.3.44 — fixed in 5.3.44, 6.1.22, 6.2.10
How to fix
Upgrade to a fixed version: Maven Org.Springframework:Spring-Webmvc 6.2.10; Spring Framework 5.3.44, 6.1.22, 6.2.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41242 or the next vulnerability affects your stack