What’s Vulnerable › Vulnerabilities
CVE-2025-41244: Broadcom VMware Aria Operations and VMware Tools Privilege Defined with Unsafe Actions Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-10-30
- EPSS: 8.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-29 · updated 2026-10-18
- Weakness: CWE-267
Description
VMware Aria Operations and VMware Tools contain a local privilege escalation vulnerability. A malicious local actor with non-administrative privileges having access to a VM with VMware Tools installed and managed by Aria Operations with SDMP enabled may exploit this vulnerability to escalate privileges to root on the same VM.
Affected products
- Debian Linux: 11.0
- VMware Aria Operations: from 8.0 before 8.18.5 — fixed in 8.18.5
- VMware Cloud Foundation: from 4.0 through 5.2.2
- VMware Cloud Foundation Operations: 9.0
- VMware Open Vm Tools: from 11.2.0 before 12.5.4; 13.0.0 — fixed in 12.5.4
- VMware Telco Cloud Infrastructure: from 2.2 through 3.0
- VMware Telco Cloud Platform: from 4.0 before 5.0.1 — fixed in 5.0.1
- VMware Tools: from 12.5.0 before 12.5.4; from 13.0.0.0 before 13.0.5.0 — fixed in 12.5.4, 13.0.5.0
How to fix
Upgrade to a fixed version: VMware Aria Operations 8.18.5; VMware Open Vm Tools 12.5.4; VMware Telco Cloud Platform 5.0.1; VMware Tools 12.5.4, 13.0.5.0. Check the vendor advisory for mitigations.
References
- http://support.broadcom.com/group/ecx/support-content-view/-/support-content/Security%20Advisories/VMSA-2025-0015--VMware-Aria-Operations-and-VMware-Tools-updates-address-multiple-vulnerabilities--CVE-2025-41244-CVE-2025-41245--CVE-2025-41246-/36149
- http://www.openwall.com/lists/oss-security/2025/09/29/10
- https://lists.debian.org/debian-lts-announce/2025/10/msg00000.html
- https://blog.nviso.eu/2025/09/29/you-name-it-vmware-elevates-it-cve-2025-41244/
- https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/36149
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-41244
Get alerted when CVE-2025-41244 or the next vulnerability affects your stack