What’s Vulnerable › Vulnerabilities
CVE-2025-41246: Improper authorisation vulnerability
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-29 · updated 2026-10-09
- Weakness: CWE-863
Description
VMware Tools for Windows contains an improper authorisation vulnerability due to the way it handles user access controls. A malicious actor with non-administrative privileges on a guest VM, who is already authenticated through vCenter or ESX may exploit this issue to access other guest VMs. Successful exploitation requires knowledge of credentials of the targeted VMs and vCenter or ESX.
Affected products
- VMware Tools: from 13.x.x.x before 13.0.5.0; from 12.x.x before 12.5.4; 11.x.x — fixed in 12.5.4, 13.0.5.0
How to fix
Upgrade to a fixed version: VMware Tools 12.5.4, 13.0.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41246 or the next vulnerability affects your stack