What’s Vulnerable › Vulnerabilities
CVE-2025-4127: WP SEO Structured Data Schema <= 2.7.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via Plugin Settings
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP SEO Structured Data Schema plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘Price Range’ parameter in all versions up to, and including, 2.7.11 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts that will execute whenever an administrator accesses the plugin settings page.
Affected products
- kcseopro WP SEO Structured Data Schema: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: kcseopro WP SEO Structured Data Schema 2.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-seo-structured-data-schema/trunk/lib/classes/KcSeoHelper.php#L7
- https://plugins.trac.wordpress.org/changeset/3289009/wp-seo-structured-data-schema
- https://www.wordfence.com/threat-intel/vulnerabilities/id/24f6c4e4-11c3-476f-9f50-42053b625ab8?source=cve
Get alerted when CVE-2025-4127 or the next vulnerability affects your stack