What’s Vulnerable › Vulnerabilities

CVE-2025-4128: Mattermost Guest User Information Disclosure Vulnerability

Description

Mattermost versions 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly restrict API access to team information, allowing guest users to bypass permissions and view information about public teams they are not members of via a direct API call to /api/v4/teams/{team_id}.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.5, 9.11.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4128 or the next vulnerability affects your stack