What’s Vulnerable › Vulnerabilities
CVE-2025-41368: Multiple vulnerabilities in Small HTTP server by Smallsrv
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-22
Description
Problem in the Small HTTP Server v3.06.36 service. An authenticated path traversal vulnerability in '/' allows remote users to bypass the intended restrictions of SecurityManager and display any file if they have the appropriate permissions outside the document root configured on the server.
Affected products
- Smallsrv Small HTTP: from 3.06.36 before 3.06.38 — fixed in 3.06.38
How to fix
Upgrade to a fixed version: Smallsrv Small HTTP 3.06.38. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41368 or the next vulnerability affects your stack