What’s Vulnerable › Vulnerabilities

CVE-2025-41423: Unauthorized Playbooks Post Deletion in Mattermost Playbooks Plugin

Description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint /plugins/playbooks/api/v0/signal/keywords/ignore-thread, allowing any user or attacker to delete posts containing actions created by the Playbooks bot, even without channel access or appropriate permissions.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.4.3, 9.11.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-41423 or the next vulnerability affects your stack