What’s Vulnerable › Vulnerabilities
CVE-2025-41442: Advantech iView Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability exists in Advantech iView versions prior to 5.7.05 build 7057, which could allow a reflected cross-site scripting (XSS) attack. By manipulating certain input parameters, an attacker could execute unauthorized scripts in the user's browser, potentially leading to information disclosure or other malicious activities.
Affected products
- Advantech iView: before 5.7.05.7057 — fixed in 5.7.05.7057
How to fix
Upgrade to a fixed version: Advantech iView 5.7.05.7057. Check the vendor advisory for mitigations.
References
- https://www.advantech.com/en/support/details/firmware-?id=1-HIPU-183
- https://www.cisa.gov/news-events/ics-advisories/icsa-25-191-08
Get alerted when CVE-2025-41442 or the next vulnerability affects your stack