What’s Vulnerable › Vulnerabilities
CVE-2025-41658: CODESYS Toolkit Exposes Sensitive Files via Default Permissions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-04 · updated 2026-06-17
- Weakness: CWE-276
Description
CODESYS Runtime Toolkit-based products may expose sensitive files to local low-privileged operating system users due to default file permissions.
Affected products
- CODESYS Control for BeagleBone SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for emPC-A/iMX6 SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for IOT2000 SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for Linux ARM SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for Linux SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for PFC100 SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for PFC200 SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for PLCnext SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for Raspberry Pi SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
- CODESYS Runtime Toolkit: from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS Virtual Control SL: from 0.0.0.0 before 4.16.0.0 — fixed in 4.16.0.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.16.0.0; CODESYS Control for emPC-A/iMX6 SL 4.16.0.0; CODESYS Control for IOT2000 SL 4.16.0.0; CODESYS Control for Linux ARM SL 4.16.0.0; CODESYS Control for Linux SL 4.16.0.0; CODESYS Control for PFC100 SL 4.16.0.0; CODESYS Control for PFC200 SL 4.16.0.0; CODESYS Control for PLCnext SL 4.16.0.0; CODESYS Control for Raspberry Pi SL 4.16.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.16.0.0; CODESYS Runtime Toolkit 3.5.21.20; CODESYS Virtual Control SL 4.16.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41658 or the next vulnerability affects your stack