What’s Vulnerable › Vulnerabilities
CVE-2025-41659: CODESYS Control PKI Exposure Enables Remote Certificate Access
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-04 · updated 2026-06-17
- Weakness: CWE-732
Description
A low-privileged attacker can remotely access the PKI folder of the CODESYS Control runtime system and thus read and write certificates and its keys. This allows sensitive data to be extracted or to accept certificates as trusted. Although all services remain available, only unencrypted communication is possible if the certificates are deleted.
Affected products
- CODESYS Control for BeagleBone SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for emPC-A/iMX6 SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for IOT2000 SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for Linux ARM SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for Linux SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for PFC100 SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for PFC200 SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for PLCnext SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for Raspberry Pi SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
- CODESYS Control RTE (for Beckhoff CX) SL: from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS Control RTE (SL): from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS Control Win (SL): from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS HMI (SL): from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS Runtime Toolkit: from 0.0.0.0 before 3.5.21.20 — fixed in 3.5.21.20
- CODESYS Virtual Control SL: from 0.0.0.0 before 4.17.0.0 — fixed in 4.17.0.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.17.0.0; CODESYS Control for emPC-A/iMX6 SL 4.17.0.0; CODESYS Control for IOT2000 SL 4.17.0.0; CODESYS Control for Linux ARM SL 4.17.0.0; CODESYS Control for Linux SL 4.17.0.0; CODESYS Control for PFC100 SL 4.17.0.0; CODESYS Control for PFC200 SL 4.17.0.0; CODESYS Control for PLCnext SL 4.17.0.0; CODESYS Control for Raspberry Pi SL 4.17.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.17.0.0; CODESYS Control RTE (for Beckhoff CX) SL 3.5.21.20; CODESYS Control RTE (SL) 3.5.21.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41659 or the next vulnerability affects your stack