What’s Vulnerable › Vulnerabilities
CVE-2025-4166: Vault May Include Sensitive Data in Error Logs When Using the KV v2 Plugin
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-209
Description
Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.
Affected products
- HashiCorp Vault: from 0.3.0 before 1.16.20; from 0.3.0 before 1.19.3; from 1.17.0 before 1.17.16; from 1.18.0 before 1.18.9; from 1.19.0 before 1.19.3 — fixed in 1.16.20, 1.17.16, 1.18.9, 1.19.3
- openbao: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.16.20, 1.17.16, 1.18.9, 1.19.3; openbao 2.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4166 or the next vulnerability affects your stack