What’s Vulnerable › Vulnerabilities
CVE-2025-41687: Weidmueller: Unauthenticated Stack-Based Buffer Overflow in u-link Management API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-23 · updated 2026-06-17
- Weakness: CWE-121
Description
An unauthenticated remote attacker may use a stack based buffer overflow in the u-link Management API to gain full access on the affected devices.
Affected products
- Weidmueller IE-SR-2TX-WL: from V0.0 before V1.49 — fixed in V1.49
- Weidmueller IE-SR-2TX-WL-4G-EU: from V0.0 before V1.62 — fixed in V1.62
- Weidmueller IE-SR-2TX-WL-4G-US-V: from V0.0 before V1.62 — fixed in V1.62
How to fix
Upgrade to a fixed version: Weidmueller IE-SR-2TX-WL V1.49; Weidmueller IE-SR-2TX-WL-4G-EU V1.62; Weidmueller IE-SR-2TX-WL-4G-US-V V1.62. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41687 or the next vulnerability affects your stack