What’s Vulnerable › Vulnerabilities
CVE-2025-41699: Phoenix Contact: Security Advisory for CHARX SEC-3xxx charging controllers
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-18
- Weakness: CWE-94
Description
An low privileged remote attacker with an account for the Web-based management can change the system configuration to perform a command injection as root, resulting in a total loss of confidentiality, availability and integrity due to improper control of generation of code ('Code Injection').
Affected products
- Phoenix Contact CHARX SEC-3000: before 1.7.4 — fixed in 1.7.4
- Phoenix Contact CHARX SEC-3050: before 1.7.4 — fixed in 1.7.4
- Phoenix Contact CHARX SEC-3100: before 1.7.4 — fixed in 1.7.4
- Phoenix Contact CHARX SEC-3150: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: Phoenix Contact CHARX SEC-3000 1.7.4; Phoenix Contact CHARX SEC-3050 1.7.4; Phoenix Contact CHARX SEC-3100 1.7.4; Phoenix Contact CHARX SEC-3150 1.7.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41699 or the next vulnerability affects your stack