What’s Vulnerable › Vulnerabilities
CVE-2025-41700: CODESYS Development System - Deserialization of Untrusted Data
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-10-18
- Weakness: CWE-502
Description
An unauthenticated attacker can trick a local user into executing arbitrary code by opening a deliberately manipulated CODESYS project file with a CODESYS development system. This arbitrary code is executed in the user context.
Affected products
- CODESYS: before 3.5.21.40 — fixed in 3.5.21.40
How to fix
Upgrade to a fixed version: CODESYS 3.5.21.40. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41700 or the next vulnerability affects your stack