What’s Vulnerable › Vulnerabilities
CVE-2025-41719: Sauter: Improper Validation of user-controlled data
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-22 · updated 2026-10-18
- Weakness: CWE-1286
Description
A low privileged remote attacker can corrupt the webserver users storage on the device by setting a sequence of unsupported characters which leads to deletion of all previously configured users and the creation of the default Administrator with a known default password.
Affected products
- Sauter EY-modulo 5 ecos 5 ecos504/505: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter EY-modulo 5 modu 5 modu524: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter EY-modulo 5 modu 5 modu525: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter modulo 6 devices modu612-LC: before Firmware v3.2.0 — fixed in Firmware v3.2.0
- Sauter modulo 6 devices modu660-AS: before Firmware v3.2.0 — fixed in Firmware v3.2.0
- Sauter modulo 6 devices modu680-AS: before Firmware v3.2.0 — fixed in Firmware v3.2.0
How to fix
Upgrade to a fixed version: Sauter EY-modulo 5 ecos 5 ecos504/505 Firmware v6.0; Sauter EY-modulo 5 modu 5 modu524 Firmware v6.0; Sauter EY-modulo 5 modu 5 modu525 Firmware v6.0; Sauter modulo 6 devices modu612-LC Firmware v3.2.0; Sauter modulo 6 devices modu660-AS Firmware v3.2.0; Sauter modulo 6 devices modu680-AS Firmware v3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41719 or the next vulnerability affects your stack