What’s Vulnerable › Vulnerabilities
CVE-2025-41721: Sauter: Command Injection
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-22 · updated 2026-10-18
- Weakness: CWE-77
Description
A high privileged remote attacker can influence the parameters passed to the openssl command due to improper neutralization of special elements when adding a password protected self-signed certificate.
Affected products
- Sauter EY-modulo 5 ecos 5 ecos504/505: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter EY-modulo 5 modu 5 modu524: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter EY-modulo 5 modu 5 modu525: before Firmware v6.0 — fixed in Firmware v6.0
- Sauter modulo 6 devices modu612-LC: before Firmware v3.2.0 — fixed in Firmware v3.2.0
- Sauter modulo 6 devices modu660-AS: before Firmware v3.2.0 — fixed in Firmware v3.2.0
- Sauter modulo 6 devices modu680-AS: before Firmware v3.2.0 — fixed in Firmware v3.2.0
How to fix
Upgrade to a fixed version: Sauter EY-modulo 5 ecos 5 ecos504/505 Firmware v6.0; Sauter EY-modulo 5 modu 5 modu524 Firmware v6.0; Sauter EY-modulo 5 modu 5 modu525 Firmware v6.0; Sauter modulo 6 devices modu612-LC Firmware v3.2.0; Sauter modulo 6 devices modu660-AS Firmware v3.2.0; Sauter modulo 6 devices modu680-AS Firmware v3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41721 or the next vulnerability affects your stack