What’s Vulnerable › Vulnerabilities
CVE-2025-41738: CODESYS Control - Invalid type usage in visualization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-06-17
- Weakness: CWE-843
Description
An unauthenticated remote attacker may cause the visualisation server of the CODESYS Control runtime system to access a resource with a pointer of wrong type, potentially leading to a denial-of-service (DoS) condition.
Affected products
- CODESYS Control for BeagleBone SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control For Empc-A/Imx6 Sl: from 4.5.0.0 through 4.19.0.0
- CODESYS Control for IOT2000 SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Linux ARM SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Linux SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for PFC100 SL: from 4.5.0.0 through 4.19.0.0
- CODESYS Control for PFC200 SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for PLCnext SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Raspberry Pi SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 4.5.0.0 through 4.19.0.0
- CODESYS Control RTE (SL): from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Control Rte Sl (For Beckhoff Cx): from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Control Win (SL): from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS HMI (SL): from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Remote Target Visu: from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Runtime Toolkit: from 3.5.18.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Virtual Control SL: from 4.5.0.0 before 4.19.0.0 — fixed in 4.19.0.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.19.0.0; CODESYS Control for IOT2000 SL 4.19.0.0; CODESYS Control for Linux ARM SL 4.19.0.0; CODESYS Control for Linux SL 4.19.0.0; CODESYS Control for PFC200 SL 4.19.0.0; CODESYS Control for PLCnext SL 4.19.0.0; CODESYS Control for Raspberry Pi SL 4.19.0.0; CODESYS Control RTE (SL) 3.5.21.40; CODESYS Control Rte Sl (For Beckhoff Cx) 3.5.21.40; CODESYS Control Win (SL) 3.5.21.40; CODESYS HMI (SL) 3.5.21.40; CODESYS Remote Target Visu 3.5.21.40. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41738 or the next vulnerability affects your stack