What’s Vulnerable › Vulnerabilities
CVE-2025-41739: CODESYS Control - Linux/QNX SysSocket flaw
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-06-17
- Weakness: CWE-125
Description
An unauthenticated remote attacker, who beats a race condition, can exploit a flaw in the communication servers of the CODESYS Control runtime system on Linux and QNX to trigger an out-of-bounds read via crafted socket communication, potentially causing a denial of service.
Affected products
- CODESYS Control for BeagleBone SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for emPC-A/iMX6 SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for IOT2000 SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Linux ARM SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Linux SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for PFC100 SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for PFC200 SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for PLCnext SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for Raspberry Pi SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Edge Gateway for Linux: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS PLCHandler: from 3.5.21.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Remote Target Visu: from 3.5.21.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS Runtime Toolkit: from 3.5.21.0 before 3.5.21.40 — fixed in 3.5.21.40
- CODESYS TargetVisu for Linux SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
- CODESYS Virtual Control SL: from 4.15.0.0 before 4.19.0.0 — fixed in 4.19.0.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.19.0.0; CODESYS Control for emPC-A/iMX6 SL 4.19.0.0; CODESYS Control for IOT2000 SL 4.19.0.0; CODESYS Control for Linux ARM SL 4.19.0.0; CODESYS Control for Linux SL 4.19.0.0; CODESYS Control for PFC100 SL 4.19.0.0; CODESYS Control for PFC200 SL 4.19.0.0; CODESYS Control for PLCnext SL 4.19.0.0; CODESYS Control for Raspberry Pi SL 4.19.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.19.0.0; CODESYS Edge Gateway for Linux 4.19.0.0; CODESYS PLCHandler 3.5.21.40. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41739 or the next vulnerability affects your stack