What’s Vulnerable › Vulnerabilities
CVE-2025-41743: Sprecher Automation: SPRECON-E series prone to weak encryption of update files
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-09-26
- Weakness: CWE-326
Description
Insufficient encryption strength in Sprecher Automation SPRECON-E-C, SPRECON-E-P, and SPRECON-E-T3 allows a local unprivileged attacker to extract data from update images and thus obtain limited information about the architecture and internal processes.
Affected products
- Sprecher-Automation Sprecon-E-C Firmware: before 9.0 — fixed in 9.0
- Sprecher-Automation Sprecon-E-P Firmware: before 9.0 — fixed in 9.0
- Sprecher-Automation Sprecon-E-T3 Firmware: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: Sprecher-Automation Sprecon-E-C Firmware 9.0; Sprecher-Automation Sprecon-E-P Firmware 9.0; Sprecher-Automation Sprecon-E-T3 Firmware 9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-41743 or the next vulnerability affects your stack