What’s Vulnerable › Vulnerabilities
CVE-2025-4230: PAN-OS: Authenticated Admin Command Injection Vulnerability Through CLI
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability in Palo Alto Networks PAN-OS® software enables an authenticated administrator to bypass system restrictions and run arbitrary commands as a root user. To be able to exploit this issue, the user must have access to the PAN-OS CLI. The security risk posed by this issue is significantly minimized when CLI access is restricted to a limited group of administrators. Cloud NGFW and Prisma® Access are not affected by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 11.2.0 before 11.2.6; from 11.1.0 before 11.1.10; from 10.2.0 before 10.2.14; from 10.1.0 before 10.1.14-h15 — fixed in 10.1.14-h15, 10.2.14, 11.1.10, 11.2.6
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.14-h15, 10.2.14, 11.1.10, 11.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4230 or the next vulnerability affects your stack