What’s Vulnerable › Vulnerabilities
CVE-2025-4231: PAN-OS: Authenticated Admin Command Injection Vulnerability in the Management Web Interface
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability in Palo Alto Networks PAN-OS® enables an authenticated administrative user to perform actions as the root user. The attacker must have network access to the management web interface and successfully authenticate to exploit this issue. Cloud NGFW and Prisma Access are not impacted by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 10.2.0 before 10.2.8; from 11.0.0 before 11.0.3 — fixed in 10.2.8, 11.0.3
- Palo Alto Networks PAN-OS: from 11.0.0 before 11.0.3; from 10.2.0 before 10.2.8; 10.1.0 — fixed in 11.0.3, 10.2.8
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.8, 11.0.3; Palo Alto Networks PAN-OS 11.0.3, 10.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4231 or the next vulnerability affects your stack