What’s Vulnerable › Vulnerabilities
CVE-2025-4232: GlobalProtect: Authenticated Code Injection Through Wildcard on macOS
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-155
Description
An improper neutralization of wildcards vulnerability in the log collection feature of Palo Alto Networks GlobalProtect™ app on macOS allows a non administrative user to escalate their privileges to root.
Affected products
- Palo Alto Networks GlobalProtect App: from 6.0.0 before 6.2.8; from 6.3.0 before 6.3.3 — fixed in 6.2.8, 6.3.3
- Palo Alto Networks GlobalProtect App: from 6.3 before 6.3.3; from 6.2.0 before 6.2.8-h2; 6.1.0, 6.0.0 — fixed in 6.3.3, 6.2.8-h2
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 6.2.8, 6.3.3; Palo Alto Networks GlobalProtect App 6.3.3, 6.2.8-h2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4232 or the next vulnerability affects your stack