What’s Vulnerable › Vulnerabilities
CVE-2025-42620: CSRF vulnerability in CIRCL Vulnerability-Lookup
- Severity: high (CVSS 8.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-14
- Weakness: CWE-79
Description
In affected versions, vulnerability-lookup handled user-controlled content in comments and bundles in an unsafe way, which could lead to stored Cross-Site Scripting (XSS). On the backend, the related_vulnerabilities field of bundles accepted arbitrary strings without format validation or proper sanitization. On the frontend, comment and bundle descriptions were converted from Markdown to HTML and then injected directly into the DOM using string templates and innerHTML. This combination allowed an attacker who could create or edit comments or bundles to store crafted HTML/JavaScript payloads which would later be rendered and executed in the browser of any user visiting the affected profile page (user.html). This issue affects Vulnerability-Lookup: before 2.18.0.
Affected products
- CIRCL Vulnerability-Lookup: before 2.18.0 — fixed in 2.18.0
How to fix
Upgrade to a fixed version: CIRCL Vulnerability-Lookup 2.18.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-42620 or the next vulnerability affects your stack