What’s Vulnerable › Vulnerabilities
CVE-2025-4278: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in GitLab
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-80
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting with 18.0 before 18.0.2. Under certain conditions html injection in new search page could lead to account takeover.
Affected products
- GitLab: from 18.0.0 before 18.0.2 — fixed in 18.0.2
How to fix
Upgrade to a fixed version: GitLab 18.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4278 or the next vulnerability affects your stack