What’s Vulnerable › Vulnerabilities
CVE-2025-43015
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-17 · updated 2026-06-17
- Weakness: CWE-1188
Description
In JetBrains RubyMine before 2025.1 remote Interpreter overwrote ports to listen on all interfaces
Affected products
- JetBrains RubyMine: before 2025.1 — fixed in 2025.1
How to fix
Upgrade to a fixed version: JetBrains RubyMine 2025.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43015 or the next vulnerability affects your stack