What’s Vulnerable › Vulnerabilities
CVE-2025-43016
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-25 · updated 2026-06-17
- Weakness: CWE-23
Description
In JetBrains Rider before 2025.1.2 custom archive unpacker allowed arbitrary file overwrite during remote debug session
Affected products
- JetBrains Rider: before 2025.1.2 — fixed in 2025.1.2
How to fix
Upgrade to a fixed version: JetBrains Rider 2025.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43016 or the next vulnerability affects your stack