What’s Vulnerable › Vulnerabilities
CVE-2025-43018: Certain HP LaserJet Pro Printers – Potential Information Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-200
Description
Certain HP LaserJet Pro printers may be vulnerable to information disclosure when a non-authenticated user queries a device’s local address book.
Affected products
- HP W1A28A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A29A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A30A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A31A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A32A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A33A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A34A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A35A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A38A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A75A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A76A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A77A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A78A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A79A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A80A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A81A Firmware: before 002.2508a — fixed in 002.2508a
- HP W1A82A Firmware: before 002.2508a — fixed in 002.2508a
How to fix
Upgrade to a fixed version: HP W1A28A Firmware 002.2508a; HP W1A29A Firmware 002.2508a; HP W1A30A Firmware 002.2508a; HP W1A31A Firmware 002.2508a; HP W1A32A Firmware 002.2508a; HP W1A33A Firmware 002.2508a; HP W1A34A Firmware 002.2508a; HP W1A35A Firmware 002.2508a; HP W1A38A Firmware 002.2508a; HP W1A75A Firmware 002.2508a; HP W1A76A Firmware 002.2508a; HP W1A77A Firmware 002.2508a. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43018 or the next vulnerability affects your stack