What’s Vulnerable › Vulnerabilities

CVE-2025-43025: HP Universal Print Driver – Potential Denial of Service

Description

HP Universal Print Driver is potentially vulnerable to denial of service due to buffer overflow in versions of UPD 7.4 or older (e.g., v7.3.x, v7.2.x, v7.1.x, etc.).

Affected products

How to fix

Upgrade to a fixed version: HP Universal Print Driver 61.330.01.26178. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-43025 or the next vulnerability affects your stack