What’s Vulnerable › Vulnerabilities
CVE-2025-4315: CubeWP – All-in-One Dynamic Content Framework <= 1.1.23 - Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
- Weakness: CWE-269
Description
The CubeWP – All-in-One Dynamic Content Framework plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.1.23. This is due to the plugin allowing a user to update arbitrary user meta through the update_user_meta() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to that of an administrator.
Affected products
- Imran Tauqeer CubeWP: before 1.1.24 — fixed in 1.1.24
How to fix
Upgrade to a fixed version: Imran Tauqeer CubeWP 1.1.24. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/cubewp-framework/tags/1.1.23/cube/classes/class-cubewp-rest-api.php#L691
- https://plugins.trac.wordpress.org/changeset/3306925/cubewp-framework#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/430b7e72-72b8-4cf8-99f4-ee1d1d4b4f24?source=cve
Get alerted when CVE-2025-4315 or the next vulnerability affects your stack