What’s Vulnerable › Vulnerabilities

CVE-2025-4316

Description

Improper access control in PAM feature in Devolutions Server allows a PAM user to self approve their PAM requests even if disallowed by the configured policy via specific user interface actions. This issue affects Devolutions Server versions from 2025.1.3.0 through 2025.1.6.0, and all versions up to 2024.3.15.0.

Affected products

How to fix

Upgrade to a fixed version: Devolutions Server 2024.3.17.0, 2025.1.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-4316 or the next vulnerability affects your stack