What’s Vulnerable › Vulnerabilities
CVE-2025-4318: Input validation issue in AWS Amplify Studio UI component properties
- Severity: critical (CVSS 9.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-05 · updated 2026-07-29
- Weakness: CWE-95
Description
The AWS Amplify Studio UI component property expressions in the aws-amplify/amplify-codegen-ui package lack input validation. This could potentially allow an authenticated user who has access to create or modify components to run arbitrary JavaScript code during the component rendering and build process.
Affected products
- Amazon Amplify Studio: from 0.1.0 before 2.20.3 — fixed in 2.20.3
How to fix
Upgrade to a fixed version: Amazon Amplify Studio 2.20.3. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2025-010/
- https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.3
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-hf3j-86p7-mfw8
- https://blog.securelayer7.net/cve-2025-4318-aws-amplify-rce/
- https://github.com/aws-amplify/amplify-codegen-ui/commit/ca98c38b7c3d69ae7c94d2f62b51e32e8165dae6
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-hf3j-86p7-mfw8
- https://blog.securelayer7.net/cve-2025-4318-aws-amplify-rce/
Get alerted when CVE-2025-4318 or the next vulnerability affects your stack