What’s Vulnerable › Vulnerabilities
CVE-2025-43187
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
Description
This issue was addressed by removing the vulnerable code. This issue is fixed in macOS Sequoia 15.6, macOS Sonoma 14.7.7, macOS Ventura 13.7.7. Running an hdiutil command may unexpectedly execute arbitrary code.
Affected products
- Apple macOS: from 13.0 before 13.7.7; from 14.0 before 14.7.7; from 15.0 before 15.6 — fixed in 13.7.7, 14.7.7, 15.6
How to fix
Upgrade to a fixed version: Apple macOS 13.7.7, 14.7.7, 15.6. Check the vendor advisory for mitigations.
References
- https://support.apple.com/en-us/124149
- https://support.apple.com/en-us/124150
- https://support.apple.com/en-us/124151
- http://seclists.org/fulldisclosure/2025/Jul/32
- http://seclists.org/fulldisclosure/2025/Jul/33
- http://seclists.org/fulldisclosure/2025/Jul/34
Get alerted when CVE-2025-43187 or the next vulnerability affects your stack