What’s Vulnerable › Vulnerabilities
CVE-2025-43504
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-04 · updated 2026-10-18
- Weakness: CWE-119
Description
A buffer overflow was addressed with improved bounds checking. This issue is fixed in Xcode 26.1. A user in a privileged network position may be able to cause a denial-of-service.
Affected products
- Apple Xcode: before 26.1 — fixed in 26.1
How to fix
Upgrade to a fixed version: Apple Xcode 26.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43504 or the next vulnerability affects your stack