What’s Vulnerable › Vulnerabilities
CVE-2025-43515
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-18
- Weakness: CWE-284
Description
The issue was addressed by refusing external connections by default. This issue is fixed in Compressor 4.11.1. An unauthenticated user on the same network as a Compressor server may be able to execute arbitrary code.
Affected products
- Apple Compressor: before 4.11.1 — fixed in 4.11.1
How to fix
Upgrade to a fixed version: Apple Compressor 4.11.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43515 or the next vulnerability affects your stack