What’s Vulnerable › Vulnerabilities
CVE-2025-43575: Acrobat Reader | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-787
Description
Acrobat Reader versions 24.001.30235, 20.005.30763, 25.001.20521 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30002 before 20.005.30774; from 24.0.0 before 24.001.30254 — fixed in 20.005.30774, 24.001.30254
- Adobe Acrobat DC: from 15.008.20082 before 25.001.20531; from 15.008.20082 before 25.001.20529 — fixed in 25.001.20529, 25.001.20531
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30774 — fixed in 20.005.30774
- Adobe Acrobat Reader: from 15.008.20082 before 25.001.20531; from 15.008.20082 before 25.001.20529 — fixed in 25.001.20529, 25.001.20531
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30774, 24.001.30254; Adobe Acrobat DC 25.001.20529, 25.001.20531; Adobe Acrobat Reader 20.005.30774; Adobe Acrobat Reader 25.001.20529, 25.001.20531. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43575 or the next vulnerability affects your stack