What’s Vulnerable › Vulnerabilities
CVE-2025-43718
- Severity: low (CVSS 2.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-12
- Weakness: CWE-674
Description
Poppler 24.06.1 through 25.x before 25.04.0 allows stack consumption and a SIGSEGV via deeply nested structures within the metadata (such as GTS_PDFEVersion) of a PDF document, e.g., a regular expression for a long pdfsubver string. This occurs in Dict::lookup, Catalog::getMetadata, and associated functions in PDFDoc, with deep recursion in the regex executor (std::__detail::_Executor).
Affected products
- poppler: from 24.06.1 before 25.04.0 — fixed in 25.04.0
How to fix
Upgrade to a fixed version: poppler 25.04.0. Check the vendor advisory for mitigations.
References
- https://github.com/ShadowByte1/CVE-Reports/blob/main/CVE-2025-43718.md
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/f54b815672117c250420787c8c006de98e8c7408
Get alerted when CVE-2025-43718 or the next vulnerability affects your stack