What’s Vulnerable › Vulnerabilities

CVE-2025-43794

Description

Stored cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions allows remote authenticated attackers with the instance administrator role to inject arbitrary web script or HTML into all pages via a crafted payload injected into the Instance Configuration's (1) CDN Host HTTP text field or (2) CDN Host HTTPS text field.

Affected products

How to fix

Upgrade to a fixed version: Liferay Digital Experience Platform 2023.q3.5, 7.3; Liferay Portal 7.4.3.112. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-43794 or the next vulnerability affects your stack