What’s Vulnerable › Vulnerabilities

CVE-2025-43804

Description

Cross-site scripting (XSS) vulnerability in Search widget in Liferay Portal 7.4.3.93 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 allows remote attackers to inject arbitrary web script or HTML via the _com_liferay_portal_search_web_portlet_SearchPortlet_userId parameter.

Affected products

How to fix

Upgrade to a fixed version: Liferay Portal 7.4.3.112. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-43804 or the next vulnerability affects your stack