What’s Vulnerable › Vulnerabilities
CVE-2025-4384: Certificate validity not properly verified
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-06 · updated 2026-06-17
- Weakness: CWE-298
Description
The MQTT add-on of PcVue fails to verify that a remote device’s certificate has not already expired or has not yet become valid. This allows malicious devices to present certificates that are not rejected properly. The use of a client certificate reduces the risk for random devices to take advantage of this flaw.
Affected products
- arcinfo PcVue: from 16.0 before 16.2.5; from 15.0 before 15.2.12 — fixed in 15.2.12, 16.2.5
How to fix
Upgrade to a fixed version: arcinfo PcVue 15.2.12, 16.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4384 or the next vulnerability affects your stack