What’s Vulnerable › Vulnerabilities
CVE-2025-43860: OpemEMR Vulnerable to Stored XSS Attack in the Additional Address Section of Patient Demographics
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. A stored cross-site scripting (XSS) vulnerability in versions prior to 7.0.3.4 allows any authenticated user with patient creation and editing privileges to inject arbitrary JavaScript code into the system by entering malicious payloads in the (1) Text Box fields of Address, Address Line 2, Postal Code and City fields and (2) Drop Down menu options of Address Use, State and Country of the Additional Addresses section of the Contact tab in Patient Demographics. The injected script can execute in two scenarios: (1) dynamically during form input, and (2) when the form data is later loaded for editing. Version 7.0.3.4 contains a patch for the issue.
Affected products
- openemr: before 7.0.3.4 — fixed in 7.0.3.4
How to fix
Upgrade to a fixed version: openemr 7.0.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-43860 or the next vulnerability affects your stack